GHSA-pgq6-ccqj-hpqr

Elasticsearch privilege escalation

At a glance

Published
Updated
CVE
CVE-2022-23708
Aliases
BIT-elasticsearch-2022-23708
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Description

A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index. Users running a cluster on an affected version that had previously been upgraded from 6.x, should upgrade to 7.17.1. Users that are planning to upgrade from 6.x should not perform an upgrade from 6.x to versions 7.16 through 7.17.0 and should use 7.17.1+ for upgrades from 6.x.

Affected packages

PackageVersions
Maven · org.elasticsearch:elasticsearchintroduced 7.16.0, fixed 7.17.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database