GHSA-pgq7-jcj5-xx6h
Apache Druid before 0.23.0 vulnerable to clickjacking
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2022-28889
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Description
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.apache.druid:druid | introduced 0, fixed 0.23.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2022-28889 ADVISORY
- https://github.com/apache/druid PACKAGE
- https://lists.apache.org/thread/t3nsq4crdr8wqgmj721d2wg6pf26s5cw WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |