GHSA-pm48-cvv2-29q5

Ansible Uses Plugins That Disclose Credentials

En bref

Publiée
Mise à jour
CVE
CVE-2019-14846
Alias
PYSEC-2019-4
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Ansible, all ansible_engine-2.x versions and ansible_engine-3.x up to ansible_engine-3.5, was logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.6.20
PyPI · ansibleintroduced 2.7.0a1, fixed 2.7.14
PyPI · ansibleintroduced 2.8.0a1, fixed 2.8.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database