GHSA-pwr2-4v36-6qpr
orjson does not limit recursion for deeply nested JSON documents
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-27454
- Alias
- PYSEC-2024-40
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
orjson.loads in orjson before 3.9.15 does not limit recursion for deeply nested JSON documents.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · orjson | introduced 0, fixed 3.9.15 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-27454 ADVISORY
- https://github.com/ijl/orjson/issues/458 WEB
- https://github.com/ijl/orjson/commit/b0e4d2c06ce06c6e63981bf0276e4b7c74e5845e WEB
- https://github.com/ijl/orjson PACKAGE
- https://github.com/ijl/orjson/blob/master/CHANGELOG.md#3915 WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/orjson/PYSEC-2024-40.yaml WEB
- https://monicz.dev/CVE-2024-27454 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |