GHSA-qvqm-h22r-4cp9

Laravel Framework RCE Vulnerability

At a glance

Published
Updated
CVE
CVE-2018-15133
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

In Laravel Framework through 5.5.40 and 5.6.x through 5.6.29, remote code execution might occur as a result of an unserialize call on a potentially untrusted X-XSRF-TOKEN value. This involves the decrypt method in `Illuminate/Encryption/Encrypter.php` and PendingBroadcast in `gadgetchains/Laravel/RCE/3/chain.php` in phpggc. The attacker must know the application key, which normally would never occur, but could happen if the attacker previously had privileged access or successfully accomplished a previous attack.

Affected packages

PackageVersions
Packagist · laravel/frameworkintroduced 0, last affected 5.5.40
Packagist · laravel/frameworkintroduced 5.6.0, fixed 5.6.30

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database