GHSA-qxpc-96fq-wwmg

Apache Cassandra is vulnerable to privilege escalation in an mTLS environment using MutualTlsAuthenticator

At a glance

Published
Updated
CVE
CVE-2026-27314
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY. Users are recommended to upgrade to version 5.0.7+, which fixes this issue.

Affected packages

PackageVersions
Maven · org.apache.cassandra:cassandra-allintroduced 5.0-alpha1, fixed 5.0.7

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database