GHSA-r5m4-5vww-w9f5

OSGeo gdal has a heap-based buffer overflow

En bref

Publiée
Mise à jour
CVE
CVE-2026-8212
Alias
BIT-gdal-2026-8212, PYSEC-2026-4
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS_V4
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Description

A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch commit sha is 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.

Paquets affectés

PaquetVersions
PyPI · gdalintroduced 0, fixed 3.13.0RC1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database