GHSA-r69c-5j7c-vm6q

Cross-site Scripting in Jenkins

At a glance

Published
Updated
CVE
CVE-2017-2601
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

Jenkins before versions 2.44 and 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.32.2
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.34, fixed 2.44

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database