GHSA-r69c-5j7c-vm6q
Cross-site Scripting in Jenkins
At a glance
- Published
- Updated
- CVE
- CVE-2017-2601
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Description
Jenkins before versions 2.44 and 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.32.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.34, fixed 2.44 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-2601 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/fd2e081b947124c90bcd97bfc55e1a7f2ef41a74 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2601 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2017-02-01 WEB
- http://www.openwall.com/lists/oss-security/2022/04/12/5 WEB
- http://www.openwall.com/lists/oss-security/2022/05/17/8 WEB
- http://www.openwall.com/lists/oss-security/2022/06/22/3 WEB
- http://www.openwall.com/lists/oss-security/2022/06/30/3 WEB
- http://www.openwall.com/lists/oss-security/2022/10/19/3 WEB
- http://www.securityfocus.com/bid/95960 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |