GHSA-r9q2-3r6x-qmgp
Inadequate Encryption Strength in Jenkins
At a glance
- Published
- Updated
- CVE
- CVE-2017-2598
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Description
Jenkins before versions 2.44 and 2.32.2 uses AES ECB block cipher mode without IV for encrypting secrets which makes Jenkins and the stored secrets vulnerable to unnecessary risks (SECURITY-304).
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.32.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.34, fixed 2.44 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-2598 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/e6aa166246d1734f4798a9e31f78842f4c85c28b WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2598 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2017-02-01 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |