GHSA-rp8m-h266-53jh
python-apt Flawed Package Integrity Check
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-15795
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · python-apt | introduced 0, fixed 0.8.3ubuntu7.5 |
| PyPI · python-apt | introduced 0.9.0, fixed 0.9.3.5ubuntu3 |
| PyPI · python-apt | introduced 1.0.0, fixed 1.1.0 |
| PyPI · python-apt | introduced 1.2.0, fixed 1.6.5ubuntu0.1 |
| PyPI · python-apt | introduced 1.7.0, fixed 1.9.0ubuntu1.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2019-15795 ADVISORY
- https://github.com/excid3/python-apt PACKAGE
- https://usn.ubuntu.com/4247-1 WEB
- https://usn.ubuntu.com/4247-3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |