GHSA-rrj2-ph5q-jxw2

jquery-validation vulnerable to Cross-site Scripting

En bref

Publiée
Mise à jour
CVE
CVE-2025-3573
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N

Description

Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.

Paquets affectés

PaquetVersions
npm · jquery-validationintroduced 0, fixed 1.20.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database