GHSA-v33x-prhc-gph5

Insufficiently Protected Credentials and Improper Authentication in Spring Security

En bref

Publiée
Mise à jour
CVE
CVE-2019-11272
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

Spring Security, versions 4.2.x up to 4.2.12, and older unsupported versions support plain text passwords using PlaintextPasswordEncoder. If an application using an affected version of Spring Security is leveraging PlaintextPasswordEncoder and a user has a null encoded password, a malicious user (or attacker) can authenticate using a password of ?null?.

Paquets affectés

PaquetVersions
Maven · org.springframework.security:spring-security-coreintroduced 0, fixed 4.2.13
Maven · org.springframework.security:spring-security-casintroduced 0, fixed 4.2.13.RELEASE

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database