GHSA-v5m6-2m78-4vr2
Magento 2 Community Edition XSS Vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-7877
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to manage orders can inject malicious javascript.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · magento/community-edition | introduced 2.1, fixed 2.1.18 |
| Packagist · magento/community-edition | introduced 2.2, fixed 2.2.9 |
| Packagist · magento/community-edition | introduced 2.3, fixed 2.3.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2019-7877 ADVISORY
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-7877.yaml WEB
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13 WEB
- https://web.archive.org/web/20220121051916/https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |