GHSA-v62j-cxhh-fq22

graphql-java vulnerable to Denial of Service via GraphQL query that consumes CPU resources

En bref

Publiée
Mise à jour
CVE
CVE-2022-37734
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

graphql-java before 19.0, 18.3, and 17.4 is vulnerable to Denial of Service. An attacker send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0, 18.3, and 17.4.

Paquets affectés

PaquetVersions
Maven · com.graphql-java:graphql-javaintroduced 0, fixed 17.4
Maven · com.graphql-java:graphql-javaintroduced 18.0, fixed 18.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database