GHSA-v6rp-3r3v-hf4p

Ruby OpenSSL DoS Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2017-14033
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

The decode method in the `OpenSSL::ASN1` module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string. The `openssl` gem that contains this module is patched in version 2.0.0.

Paquets affectés

PaquetVersions
RubyGems · opensslintroduced 0, fixed 2.0.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database