GHSA-v973-fxgf-6xhp

mako is vulnerable to Regular Expression Denial of Service

En bref

Publiée
Mise à jour
CVE
CVE-2022-40023
Alias
PYSEC-2022-260
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

Paquets affectés

PaquetVersions
PyPI · makointroduced 0, fixed 1.2.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database