GHSA-vmfx-gcfq-wvm2

Nokogiri implementation of libxslt vulnerable to heap corruption

En bref

Publiée
Mise à jour
CVE
CVE-2019-5815
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Type confusion in `xsltNumberFormatGetMultipleLevel` prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data. Nokogiri prior to version 1.10.5 contains a vulnerable version of libxslt. Nokogiri version 1.10.5 upgrades the dependency to libxslt 1.1.34, which contains a patch for this issue.

Paquets affectés

PaquetVersions
RubyGems · nokogiriintroduced 0, fixed 1.10.5

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database