GHSA-w2p4-2c8c-2g7h

Magento OS command injection via the customer attribute save controller

At a glance

Published
Updated
CVE
CVE-2021-21015
Aliases
BIT-magento-2021-21015
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to an OS command injection via the customer attribute save controller. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 0, fixed 2.3.6-p1
Packagist · magento/community-editionintroduced 2.4.0, fixed 2.4.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database