GHSA-wmcc-9vch-jmx4

Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

En bref

Publiée
Mise à jour
CVE
CVE-2025-23015
Alias
BIT-cassandra-2025-23015
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.cassandra:cassandra-allintroduced 5.0-alpha1, fixed 5.0.3
Maven · org.apache.cassandra:cassandra-allintroduced 4.1-alpha1, fixed 4.1.8
Maven · org.apache.cassandra:cassandra-allintroduced 4.0-alpha1, fixed 4.0.16
Maven · org.apache.cassandra:cassandra-allintroduced 3.1, fixed 3.11.18
Maven · org.apache.cassandra:cassandra-allintroduced 0, fixed 3.0.31

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database