GHSA-x2q2-8pwq-fr5r
Jenkins allows Bypass of Access Restrictions
At a glance
- Published
- Updated
- CVE
- CVE-2015-5325
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
Description
Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP slave. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3665.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.625.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.626, fixed 1.638 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5325 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/054a329c59171ca12ff98f7063ce7fd053ee08bf WEB
- https://access.redhat.com/errata/RHSA-2016:0070 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-11-11 WEB
- http://rhn.redhat.com/errata/RHSA-2016-0489.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |