GHSA-x368-4g9h-fvv4

vLLM makes Use of Uninitialized Resource

At a glance

Published
Updated
CVE
CVE-2026-7141
Aliases
PYSEC-2026-2306
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Description

A vulnerability was found in vLLM up to 0.19.0. The affected element is the function has_mamba_layers of the file vllm/v1/kv_cache_interface.py of the component KV Block Handler. Performing a manipulation results in uninitialized resource. It is possible to initiate the attack remotely. The attack is considered to have high complexity. The exploitability is described as difficult. The exploit has been made public and could be used. The patch is named 1ad67864c0c20f167929e64c875f5c28e1aad9fd. To fix this issue, it is recommended to deploy a patch.

Affected packages

PackageVersions
PyPI · vllmintroduced 0, fixed 0.19.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database