GHSA-x3rc-cxv7-6xp6
Cross-site Scripting in Jenkins Core
At a glance
- Published
- Updated
- CVE
- CVE-2017-17383
- CVSS_V3
- CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
Jenkins through 2.93 allows remote authenticated administrators to conduct XSS attacks via a crafted tool name in a job configuration form, as demonstrated by the JDK tool in Jenkins core and the Ant tool in the Ant plugin, aka SECURITY-624.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.94 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-17383 ADVISORY
- https://jenkins.io/security/advisory/2017-12-05 WEB
- http://vsintelli.com/portal/blog/23-security-advisory-2017-12-04 WEB
- http://www.securityfocus.com/bid/102130 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |