GHSA-x6jw-2f23-mc5j

Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

At a glance

Published
Updated
CVE
CVE-2018-1000068
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Description

An improper input validation vulnerability exists in Jenkins versions 2.106 and earlier, and LTS 2.89.3 and earlier, that allows an attacker to access plugin resource files in the META-INF and WEB-INF directories that should not be accessible, if the Jenkins home directory is on a case-insensitive file system.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.89.4
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.90, fixed 2.107

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database