GHSA-xhfx-rm8q-c3xv
Moodle Vulnerable to Reflected Cross-site Scripting
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2021-20183
- Alias
- BIT-moodle-2021-20183
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Description
It was found in Moodle before version 4.0.0-beta that some search inputs were vulnerable to reflected Cross-site Scripting (XSS) due to insufficient escaping of search queries.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · moodle/moodle | introduced 3.10, fixed 4.0.0-beta |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2021-20183 ADVISORY
- https://github.com/moodle/moodle/commit/dc9de7b0d487b73c23c221dc0b8b6e01654921f3 WEB
- https://moodle.org/mod/forum/discuss.php?d=417166 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |