GHSA-xhm9-gwgw-3q2q
@payloadcms/plugin-multi-tenant has a cross-tenant create issue
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-105864
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Description
### Impact An authenticated user limited to one tenant could create a record in another tenant. This requires the multi-tenant plugin with at least one tenant-enabled collection. Reads and direct edits to an existing target-tenant document were not bypassed. You are affected if: - You are using @payloadcms/plugin-multi-tenant ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds You can add access control with `accessResultOverride` on the multi-tenant collection config to ensure a user has access to the tenant before creating.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · @payloadcms/plugin-multi-tenant | introduced 0, fixed 3.90.0 |
| npm · @payloadcms/plugin-multi-tenant | introduced 4.0.0-canary.0, fixed 4.0.0-canary.34 |
Références
- https://github.com/payloadcms/payload/security/advisories/GHSA-xhm9-gwgw-3q2q WEB
- https://nvd.nist.gov/vuln/detail/CVE-2026-105864 ADVISORY
- https://github.com/payloadcms/payload/commit/b8fc06a18afb6974dc07f95ac1e541c716e5926b WEB
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.90.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |