GHSA-xp2f-9mx3-3c6p

Moodle PostScript Code Injection

En bref

Publiée
Mise à jour
CVE
CVE-2022-35649
Alias
BIT-moodle-2022-35649
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Paquets affectés

PaquetVersions
Packagist · moodle/moodleintroduced 3.9, fixed 3.9.15
Packagist · moodle/moodleintroduced 3.11, fixed 3.11.8
Packagist · moodle/moodleintroduced 4.0, fixed 4.0.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database