GHSA-xqxw-r767-67m7
mem0ai mem0 has an Improper Input Validation Issue
At a glance
- Published
- Updated
- CVE
- CVE-2026-7597
- Aliases
- PYSEC-2026-2636
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
Description
A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vector_stores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.
Affected packages
| Package | Versions |
|---|---|
| PyPI · mem0ai | introduced 0, fixed 2.0.0b2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-7597 ADVISORY
- https://github.com/mem0ai/mem0/issues/3778 WEB
- https://github.com/mem0ai/mem0/pull/4833 WEB
- https://github.com/mem0ai/mem0/commit/62dca096f9236010ca15fea9ba369ba740b86b7a WEB
- https://github.com/mem0ai/mem0 PACKAGE
- https://vuldb.com/submit/805562 WEB
- https://vuldb.com/vuln/360550 WEB
- https://vuldb.com/vuln/360550/cti WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |