GHSA-xx7v-hqxh-cjr9

Apache Struts is Vulnerable to DoS via File Leak

At a glance

Published
Updated
CVE
CVE-2025-64775
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.struts:struts2-coreintroduced 6.0.0, fixed 6.8.0
Maven · org.apache.struts:struts2-coreintroduced 7.0.0, fixed 7.1.1
Maven · org.apache.struts:struts2-coreintroduced 2.0.0, last affected 2.3.37
Maven · org.apache.struts:struts2-coreintroduced 2.5.0, last affected 2.5.33

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database