PYSEC-2018-37
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2016-8614
- Alias
- GHSA-cmwx-9m2h-x7v4
Description
A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · ansible | introduced 0, fixed 2.2.0.0 |
Références
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8614 REPORT
- https://github.com/ansible/ansible-modules-core/pull/5357 WEB
- https://github.com/ansible/ansible-modules-core/pull/5353 WEB
- https://github.com/ansible/ansible-modules-core/issues/5237 REPORT
- http://www.securityfocus.com/bid/94108 WEB
- https://github.com/advisories/GHSA-cmwx-9m2h-x7v4 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |