PYSEC-2019-145
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-10206
- Alias
- GHSA-cqmr-rcpr-cxh3
Description
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · ansible | introduced 2.6.0, fixed 2.6.19, introduced 2.7.0, fixed 2.7.13, introduced 2.8.0, fixed 2.8.4 |
Références
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206 REPORT
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html WEB
- https://github.com/advisories/GHSA-cqmr-rcpr-cxh3 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |