PYSEC-2019-2
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-10156
- Alias
- GHSA-grgm-pph5-j5h7
Description
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · ansible | introduced 0, fixed 2.6.18, introduced 2.7.0, fixed 2.7.12, introduced 2.8.0, fixed 2.8.2 |
Références
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156 REPORT
- https://github.com/ansible/ansible/pull/57188 WEB
- https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html WEB
- https://access.redhat.com/errata/RHSA-2019:3744 ADVISORY
- https://access.redhat.com/errata/RHSA-2019:3789 ADVISORY
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html WEB
- https://github.com/advisories/GHSA-grgm-pph5-j5h7 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |