PYSEC-2019-3
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-10217
- Alias
- GHSA-p75j-wc34-527c
Description
A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · ansible | introduced 2.8.0, fixed 2.8.4 |
Références
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10217 REPORT
- https://github.com/ansible/ansible/issues/56269 REPORT
- https://github.com/ansible/ansible/pull/59427 WEB
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html WEB
- https://github.com/advisories/GHSA-p75j-wc34-527c ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |