PYSEC-2019-4

En bref

Publiée
Mise à jour
CVE
CVE-2019-14846
Alias
GHSA-pm48-cvv2-29q5

Description

In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.6.20, introduced 2.7.0, fixed 2.7.14, introduced 2.8.0, fixed 2.8.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database