PYSEC-2019-5

At a glance

Published
Updated
CVE
CVE-2019-3828
Aliases
GHSA-74vq-h4q8-x6jv

Description

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

Affected packages

PackageVersions
PyPI · ansibleintroduced 2.5.0, fixed 2.5.15, introduced 2.6.0, fixed 2.6.14, introduced 2.7.0, fixed 2.7.8

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database