PYSEC-2020-206

En bref

Publiée
Mise à jour
CVE
CVE-2019-14905
Alias
GHSA-frxj-5j27-f8rf

Description

A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 2.7.0, fixed 2.7.16, introduced 2.8.0, fixed 2.8.8, introduced 2.9.0, fixed 2.9.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database