PYSEC-2020-207

En bref

Publiée
Mise à jour
CVE
CVE-2020-10684
Alias
GHSA-p62g-jhg6-v3rq

Description

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 2.7.0, fixed 2.7.17, introduced 2.8.0, fixed 2.8.9, introduced 2.9.0, fixed 2.9.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database