PYSEC-2020-209

En bref

Publiée
Mise à jour
CVE
CVE-2020-14365
Alias
GHSA-m429-fhmv-c6q2

Description

A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module. GPG signatures are ignored during installation even when disable_gpg_check is set to False, which is the default behavior. This flaw leads to malicious packages being installed on the system and arbitrary code executed via package installation scripts. The highest threat from this vulnerability is to integrity and system availability.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 2.8.0, fixed 2.8.16rc1, introduced 2.9.0, fixed 2.9.14rc1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database