PYSEC-2020-217
At a glance
- Published
- Updated
- CVE
- CVE-2014-9390
- Aliases
- GHSA-6vvc-c2m3-cjf3
Description
Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions before 08-12-2014; libgit2 all versions up to 0.21.2; Egit all versions before 08-12-2014; and JGit all versions before 08-12-2014 allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.
Affected packages
| Package | Versions |
|---|---|
| PyPI · mercurial | introduced 0, fixed 3.2.3 |
References
- https://news.ycombinator.com/item?id=8769667 WEB
- http://git-blame.blogspot.com/2014/12/git-1856-195-205-214-and-221-and.html ARTICLE
- https://github.com/blog/1938-git-client-vulnerability-announced ARTICLE
- http://securitytracker.com/id?1031404 WEB
- http://article.gmane.org/gmane.linux.kernel/1853266 WEB
- http://mercurial.selenic.com/wiki/WhatsNew WEB
- http://support.apple.com/kb/HT204147 WEB
- https://libgit2.org/security/ WEB
- https://github.com/libgit2/libgit2/commit/928429c5c96a701bcbcafacb2421a82602b36915 FIX
- https://github.com/advisories/GHSA-6vvc-c2m3-cjf3 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |