PYSEC-2022-42976

En bref

Publiée
Mise à jour
CVE
CVE-2022-31777
Alias
BIT-spark-2022-31777, GHSA-43xg-8wmj-cw8h

Description

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Paquets affectés

PaquetVersions
PyPI · pysparkintroduced 0, fixed 3.2.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database