PYSEC-2023-152

En bref

Publiée
Mise à jour
CVE
CVE-2023-37379
Alias
BIT-airflow-2023-37379, GHSA-x2mh-8fmc-rqgh
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Description

Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server. Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.7.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database