PYSEC-2023-202

En bref

Publiée
Mise à jour
CVE
CVE-2023-42780
Alias
BIT-airflow-2023-42780, GHSA-cgx2-rrmr-jx43
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.7.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database