PYSEC-2023-203

At a glance

Published
Updated
CVE
CVE-2023-42792
Aliases
BIT-airflow-2023-42792, GHSA-j3w8-2p2h-mrr9
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Description

Apache Airflow, in versions prior to 2.7.2, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. Users of Apache Airflow are strongly advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.7.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database