PYSEC-2023-232

En bref

Publiée
Mise à jour
CVE
CVE-2023-47037
Alias
BIT-airflow-2023-47037, GHSA-hm9r-7f84-25c9

Description

We failed to apply CVE-2023-40611 in 2.7.1 and this vulnerability was marked as fixed then.  Apache Airflow, versions before 2.7.3, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc.  Users should upgrade to version 2.7.3 or later which has removed the vulnerability.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.7.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database