PYSEC-2023-266

En bref

Publiée
Mise à jour
CVE
CVE-2023-49920
Alias
BIT-airflow-2023-49920, GHSA-6m9r-7wrx-xmr6
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Description

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 2.7.0, fixed 2.8.0b1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database