PYSEC-2024-167

At a glance

Published
Updated
CVE
CVE-2024-39705
Aliases
GHSA-cgvx-9447-vcch

Description

NLTK through 3.8.1 allows remote code execution if untrusted packages have pickled Python code, and the integrated data package download functionality is used. This affects, for example, averaged_perceptron_tagger and punkt.

Affected packages

PackageVersions
PyPI · nltkintroduced 0, fixed 3.9

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database