PYSEC-2024-189

At a glance

Published
Updated
CVE
CVE-2024-39863
Aliases
BIT-airflow-2024-39863, GHSA-j482-47xf-p25c
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.9.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database