PYSEC-2024-190

En bref

Publiée
Mise à jour
CVE
CVE-2024-39877
Alias
BIT-airflow-2024-39877, GHSA-g5hv-r743-v8pm
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 2.4.0, fixed 2.9.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database