PYSEC-2025-36

En bref

Publiée
Mise à jour
CVE
CVE-2025-3248
Alias
GHSA-rvqx-wpfh-mfx7, PYSEC-2026-380
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.

Paquets affectés

PaquetVersions
PyPI · langflowintroduced 0, fixed 1.3.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database