PYSEC-2025-50
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-48887
- Alias
- GHSA-w6q7-j642-7c25
Description
vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file `vllm/entrypoints/openai/tool_parsers/pythonic_tool_parser.py` of versions 0.6.4 up to but excluding 0.9.0. The root cause is the use of a highly complex and nested regular expression for tool call detection, which can be exploited by an attacker to cause severe performance degradation or make the service unavailable. The pattern contains multiple nested quantifiers, optional groups, and inner repetitions which make it vulnerable to catastrophic backtracking. Version 0.9.0 contains a patch for the issue.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · vllm | introduced 0, fixed 4fc1bf813ad80172c1db31264beaef7d93fe0601 ; introduced 0.6.4, fixed 0.9.0 |
Références
- https://github.com/vllm-project/vllm/security/advisories/GHSA-w6q7-j642-7c25 ADVISORY
- https://github.com/vllm-project/vllm/security/advisories/GHSA-w6q7-j642-7c25 EVIDENCE
- https://github.com/vllm-project/vllm/commit/4fc1bf813ad80172c1db31264beaef7d93fe0601 FIX
- https://github.com/vllm-project/vllm/pull/18454 FIX
- https://github.com/vllm-project/vllm/pull/18454 REPORT
- https://github.com/advisories/GHSA-w6q7-j642-7c25 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |